"AX returned a non success result: TooManyRequests" Error Message

Microsoft has introduced a setting in D365 for priority-based throttling which may cause the following error

Error message in Dooap

Cause

Priority-based throttling is enabled by default starting with Dynamics 365 Finance version 10.0.19.

Priority-based throttling introduces service protection settings that prevent the over-utilization of resources to preserve the system's responsiveness and ensure consistent availability and performance for environments running Finance and Operations apps.

Read more at: https://docs.microsoft.com/en-us/dynamics365/fin-ops-core/dev-itpro/data-entities/priority-based-throttling or by clicking here.

Resolution

Follow the Microsoft Documentation and navigate to System Admin > Throttling Priority Mapping in D365

 

Based on your organization's authentication type set during Dooap onboarding, you will either enter the ADD application ID details or the Dooap Integration/Service account details. Below is how to fill out the table. 

Fields

  • Authentication Type

    • If you are using App registration + key: select AAD application

    • If you are using integration user name and password: select User

  • Client ID

    • If you are using AAD application (App registration + key): add the application ID that was created by you in your Azure during Dooap onboarding

    • If you are using "user + password" combination (User): leave this field empty

  • User ID

    • If you are using AAD application: leave this field empty

    • If you are using "user + password" combination: add the userID for the Dooap Integration/Service account

  • Priority
    • Set the Priority to 'High'

2021-09-13_9-16-05-1