Error: "AX Returned a Non-Success Result TooManyRequests"

What does the error message mean and how it can be resolved?

 

 

Microsoft has introduced a priority-based throttling feature in D365, which may trigger the following error: "AX returned a non-success result: TooManyRequests."

This feature is enabled by default starting with Dynamics 365 Finance version 10.0.19.

 

Cause

 

Priority-based throttling is a system feature designed to prevent the overuse of resources. It helps keep the system running smoothly by ensuring it responds quickly and remains consistently available, even during heavy use of Finance and Operations apps.

You can learn more by visiting this link.

 

Resolution

 

A resolution is to set high throttling priority for the integration user.

 

Follow the Microsoft Documentation and navigate in D365 to System Admin > Throttling Priority Mapping in D365.

 

 

Based on your organization's authentication type set during Dooap onboarding, you will either enter the ADD application details (App registration + key) or the Dooap Integration account details.

Below you can find instructions on how to fill out the table. 

Fields

  • Authentication Type

    • If you are using App registration + key select: AAD application.

    • If you are using Integration username + password select: User.

  • Client ID

    • If you are using App registration + key: add the application ID that was created by you in your Azure during Dooap onboarding.

    • If you are using Username + password: leave the field empty.

  • User ID

    • If you are using App registration + key: leave the field empty.

    • If you are using Username + password: add the userID for the Dooap Integration/Service account.

  • Priority
    • Set the Priority to High.

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