AX returned a non success result Forbidden

Error: AX returned a non success result Forbidden. Details: Please verify that the user is valid and set up correctly

Error message

Cause

Dooap cannot access D365 and thus functionality is limited.

Resolution

Check the Dooap intergration user rights in D365/AX2012.

Go to D365 system administration > Users

1. Find the correct user. 

Note! User ID for UAT and Production environments are recommended to have separate users. It is important to see that the correct user is enabled. The integration user ID should reflect the environment, for example 'dooapserviceUAT' and 'dooapservicePROD'.

2. Make sure the user is linked to a Person (worker)

3. Make sure that the user is Enabled

4. Make sure that the user has correct roles enabled. Minimum 'Dooap integration' and 'Dooap parameters'. In some cases the user might have also System Administrator role.

Dooap does not currently support the 'Assign organizations'. This means that the integration user access to legal entities in D356 cannot be limited. This might cause malfunction in Dooap master data.